Online Free Samples

Address Resolution Protocol: Theory and Simulation Exercises

Question

Task:There are two types of questions: Part A: essay questions and Part B: simulation questions
Please complete all the questions and submit your word or PDF file PLUS packet tracer file via EASTs before the due date.

Where you refer to external sources of information they should be correctly referenced according to APA 6th style.

Part A
Question 1: IP addresses are the logical identifier of devices in networks. please answer the following subquestions:

  1. What is a broadcast IP?
  2. What is a defaulty gateway? Why we need it?
  3. What is a subnet mask? What does it do?
  4. Give an example of the broadcasting uses on TCP/IP

Question 2:In your local machine CLI window, ping your default gateway and ping www.cisco.com. Once successful, type the command “arp – a” , and answer the follwoing subquestions:

  1. Take a screen shot of the output (1 mark) and explain the first two lines as examples.
  2. what does ARP stand for ?
  3. why do we need ARP?

Question 3: Issue a “netstat -r” command in the CLI window, take a screen shot of the IPv4 and IPv6 tables and explain the table content row-by-row.

Question 4: Peter has bought a Cisco switch of model 2960. He found that he can’t access the switch as it was protected by a password. Please advise him with the correct password recovery procedure and commands to clean up the old configuration.

Part B:A small business, Smart Office Services Pty Ltd, has its central office (HQ) and two branch offices (Branch 1 and Branch 2) linked via serial leased lines using routers. The network topology is given as follows. It is required that:

  1. You will be assigned a single IP to configure this network.
  2. For the private IP address, use the last 4 digits of your student ID as the first two octets of your network address. Keep other bits the same as shown in the addressing table and the figure below. For example, if your student ID is 12345678, using the last 4 digits (5678), so your main network address will be 56.78.0.0/16

Study the network topology, examine the network requirements, set up the network in Packet Tracer and complete all four sub-questions. Keep in mind that IP addresses will be needed for each of the LAN interfaces.

network topology

Question 5: Follow VLSM scheme to identify the different subnets according to network requirements. Please analyse and design the best IP addressing scheme. Create a table which lists the following information: Router Interfaces/ IP Address (Highest)/ IP Address (Lowest)/ Subnet Mask/ Default Gateway). PleaseCharles Sturt University Subject Outline ITC233 201830 SM I-7 February 2018-Version 1 Page of 11 22 show working out. Note: The lowest IP addresses of each subnet should be given to the PCs. The highest IP addresses of each subnet are given as the default gateway.

Question 6: Follow previous questions’ requirement, set up your network in Packet Tracer simulation software. Configure the three (3) routers:

  • Name the routers and label them as HQ, Branch1 and Branch
  • Set the secret password as ‘class’ on all routers (2 mark) - configure interfaces/ PCs
  • Configure TELNET on the HQ router with a password of ‘CISCO’ and (a suitable) MOTD
  • Verify basic configuration and router operations
  • What are the main components of a Cisco router?
  • You need to keep a back up of IOS of the routers. Please advise the two methods with correct procedures.

Question 7: Configure the other PCs and configure the necessary static routes (such as IP route 0.0.0.0 0.0.0.0 exit interface) on three routers to make a successful connection between routers. “Show ip route” check and screen shot each router’s routing table.

Question 8: PING from PC6 in LAN6 to PC4 in LAN4 (checked in Packet Tracer file). What protocol is used by PING? What are the names of two PING messages? Provide screen shots of successful ping (2 marks) Record the information flow in EVENT LIST of simulation and explain the PDU information such as TYPE and involved layers in each stage

Answer

Part A:

Answer to Question 1:

  1. Broadcast IP address: Broadcast IP address is considered as those IP address in which all the hosts are interlinked with the network and it assist the administrator of the network to authenticate the successful broadcast of the data packets within the network.
  2. Default Gateway: Default gateway is used as an access point and primarily utilized by the computers connected within the network o transmit the data packet to the computers which are connected in different network. It is used for communicating with the devices in another network.
  3. Subnet Mask: It is a number which is utilized for stating a range of IP address which can be applied within a network. It is also utilized for splitting a address block into smaller subnet and limiting the connection among the two subnet.
  4. Example of the broadcasting uses on TCP/IP: As an illustration of the broadcasting uses on the TCP/IP is ARP on IP. Moreover, it is also utilized for upgrading the routing tables in context to the IP address in relation to the Mac address.

Answer to Question 2:

  1. Default Gateways: 10.10.30.1
  2. Default Gateways
  3. Default Gateways
  4. Default Gateways
  5. For modifying and displaying the ARP cache, the arp command is primarily used. The ARP cache is utilized for upholding a mapping of the IP address as well as the MAC address in order to lessen the lookup period within the network.
  6. The ARP is the acronym of Address Resolution Protocol.
  7. We require the ARP for decoding the host/IP address to the MAC address and accumulating the details of the host and the IP address in a tabular form.

Answer to Question 3: IPv4 Routing Table

IPv4 Routing Table

The IPv4 tabular representation comprises of columns network destination, gateway, Netmask, metrics and interface. The netmask and network destination is utilized for attaining the details of the network ID 10.10.30.146. The gateway address states the next hop address i.e. those address which is used for getting the network address. The interface is utilized for the revelation of the accessible interface which is required for getting the network address 10.10.30.146. Similarly, the metric column is utilized for portraying the cost of the route and it can be evaluated for recognition of the suitable route from various points within the network.

IPv6 Routing Table

IPv6 Routing Table

The IPv6 routing table is utilized for sustaining the records of the IPv6 table and the prefix of the network is tallied when a packet is obtained from the destination. The on-link column is utilized for portraying the devices which are directly associated within the network and its corresponding IPv6 address.

Answer to Question 4: For recuperate the password of the CISCO 2960 model, the switch is needed to be associated with the PC utilizing the console part and the terminal emulation software. The line speed must be set at 9600 baud on the emulation software and the switch must be restarted by pushing the mode button for breaking off the flash file system.

The command utilized for cleaning the conventional configuration of the switch and reconfiguring it to the factory default setting is mentioned below:

Step 1: The switch must be associated with a PC through a console cable. The boot procedure must be interrupted by pushing the mode button.

Step 2:The flash system file must be started by utilizing the flash_init command.

Step 3: The config.text file must be deleted from the flash directory.

Step 4: If there is any VLAN configuration, it must be deleted by obliterate the vlan.dat file present within the flash directory.

Step 5: While rebooting the switch, the switch is generally positioned to its factory default conditions and the old configuration gets automatically deleted.

PART B

Answer to Question 5:
Major Network: 30.02.0.0/16
Available IP addresses in major network: 65534
Number of IP addresses needed: 6126
Available IP addresses in allocated subnets: 6138
About 9% of available major network address space is used

IP addresses in major network

IP addresses needed

Answer to Question 6:

Router Configuration
Router 0

Router>
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Branch1
Branch1(config)#
Branch1(config)#enable secret class
Branch1(config)#interface FastEthernet0/0
Branch1(config-if)#ip address 30.02.0.1 255.0.0.0
Branch1(config-if)#ip address 30.02.0.1 255.255.255.252
Branch1(config-if)#no shutdown
Branch1(config)#interface Serial0/3/0
Branch1(config-if)#ip address 30.02.0.10 255.255.255.252
Branch1(config-if)#no shutdown
Branch1(config)#ip route 30.02.8.0 255.255.255.0 30.02.17.2
Branch1(config)#ip route 30.02.16.0 255.255.255.0 30.02.18.2
Branch1(config)#ip route 30.02.18.0 255.255.255.0 30.02.17.2
Branch1(config)#

Router 1

Router>
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname HQ
HQ(config)#
HQ(config)#enable secret class
HQ(config)#interface FastEthernet0/0
HQ(config-if)#ip address 30.02.8.1 255.255.255.252
HQ(config-if)#
HQ(config-if)#exit
HQ(config)#interface Serial0/3/0
HQ(config-if)#ip address 30.02.8.10 255.255.255.252
HQ(config-if)#
HQ(config-if)#exit
HQ(config)#interface Serial0/3/1
HQ(config-if)#ip address 30.02.8.30 255.255.255.252
HQ(config-if)#
HQ(config-if)#
HQ(config-line)#password cisco
HQ(config-line)#login
HQ(config-line)#exit
HQ(config)#banner motd ^
Enter TEXT message. End with the character '^'.
Enter Password for secure login
^
HQ(config)#ip route 30.02.0.0 255.255.255.0 30.02.17.1
Branch2(config)#ip route 30.02.0.0 255.255.255.0 30.02.17.1

Router 2

Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Branch2
Branch2(config)#
Branch2(config)#enable secret class
Branch2(config)#interface FastEthernet0/0
Branch2(config-if)#ip address 30.02.16.1 255.0.0.0
Branch2(config-if)#ip address 30.02.16.1 255.255.255.252
Branch2(config-if)#no shutdown
Branch2(config)#interface Serial0/3/0
Branch2(config-if)#ip address 30.02.16.10 255.255.255.252
Branch2(config-if)#no shutdown
Branch2(config)#ip route 30.02.0.0 255.255.255.0 30.02.17.1
Branch2(config)#ip route 30.02.8.0 255.255.255.0 30.02.18.1
Branch2(config)#ip route 30.02.17.0 255.255.255.0 30.02.18.1

Answer to Question 7:The following screenshot is used for the demonstration of the IP route configuration done on the three routers namely, Branch 1, HQ and Branch 2 connected with each other. It is used for enabling the router to communicate with the PCs connected with the remote interface of the other router deployed in the network.

IP route configuration

IP route configuration

IP route configuration

Answer to Question 8: Pinging PC connected with Branch 1 interface to the PC connected with Branch 2 interface

Pinging PC connected

Pinging PC connected with Branch 2 interface to the PC connected with Branch 1 interface

Pinging PC connected with Branch 2

ICMP packets are sent from PC 0 to PC 2 and vice versa for the verification of the connection between the hosts connected in the network.

ICMP packets

Bibliography
Addis, B., Belabed, D., Bouet, M., & Secci, S. (2015, October). Virtual network functions placement and routing optimization. In Cloud Networking (CloudNet), 2015 IEEE 4th International Conference on (pp. 171-177). IEEE.

Bhatia, R., Hao, F., Kodialam, M., & Lakshman, T. V. (2015, April). Optimized network traffic engineering using segment routing. In Computer Communications (INFOCOM), 2015 IEEE Conference on (pp. 657-665). IEEE.

Muscariello, L., & Gallo, M. (2017). U.S. Patent No. 9,712,602. Washington, DC: U.S. Patent and Trademark Office.

Shen, J., Tan, H. W., Wang, J., Wang, J. W., & Lee, S. Y. (2015). A novel routing protocol providing good transmission reliability in underwater sensor networks. ????????, 16(1), 171-178.

Shen, N. (2016). U.S. Patent No. 9,246,791. Washington, DC: U.S. Patent and Trademark Office.

Singhal, S. K., Key, P. B., Zhang, M., Shen, G., Karagiannis, T., & Ganesh, A. J. (2016). U.S. Patent No. 9,407,693. Washington, DC: U.S. Patent and Trademark Office.

Sivasubramanian, S., Richardson, D. R., Scofield, C. L., & Marshall, B. E. (2017). U.S. Patent No. 9,608,957. Washington, DC: U.S. Patent and Trademark Office

Sivasubramanian, S., Richardson, D. R., Scofield, C. L., & Marshall, B. E. (2015). U.S. Patent No. 9,021,128. Washington, DC: U.S. Patent and Trademark Office.

Submit Your Networking Assignment


Amazing Features

  • Plagiarism Free Work
  • Lowest Price Guarantee
  • 100% Money Back Guarantee
  • Top Quality Work
  • On Time Deliver
  • 24 x 7 Live Help




AU ADDRESS
9/1 Pacific Highway, North Sydney, NSW, 2060
US ADDRESS
1 Vista Montana, San Jose, CA, 95134
CONTACT

+61-3-9005-6676

ESCALATION EMAIL
support@totalassignment
help.com